Developer’s problem: Windows 7 – apostrophe does not work

I found something strange. New default installation of Windows 7 had quite weird behavior of keyboard. Apostrophe, quotation mark, tilde didn’t work properly. I had to press apostrophe and then space bar to write single apostrophe.

The reason is that keyboard layout United States – International treats those keys as special. Here is quote from Microsoft support web page:

When you press the APOSTROPHE ( ‘ ) key, QUOTATION MARK ( ” ) key, ACCENT GRAVE ( ` ) key, TILDE ( ~ ) key, or ACCENT CIRCUMFLEX,. also called the CARET key, ( ^ ) key, nothing is displayed on the screen until you press a second key:

  • If you press one of the letters designated as eligible to receive an accent mark, the accented version of the letter appears.
  • If you press the key of a character that is not eligible to receive an accent mark, two separate characters appear.
  • If you press the space bar, the symbol (apostrophe, quotation mark, accent grave, tilde, accent circumflex or caret) is displayed by itself.

The following table shows the keyboard combinations that you can use to create the desired character.

Solution for developers and sys-admins is quite easy. Change keyboard layout from United States-International to something different. E.g. US.

No votes yet.
Please wait...

Leave a comment

30. January 2011 at 12:09 - Software engineering (Tags: , , , , ). Both comments and pings are currently closed.

15 Responses to “Developer’s problem: Windows 7 – apostrophe does not work”

  • pteryx says:

    Thanks You a lot for the US-International W7 keyboard hint, I was growing angry about it …

    No votes yet.
    Please wait...
  • Alessandro Drudi says:

    Thanks a lot – exactly what I was looking for

    No votes yet.
    Please wait...
  • spiq says:

    Just what I needed, thanks!

    No votes yet.
    Please wait...
  • DaSmith says:

    Oh my god that was so annoying! Thank you very much :)

    No votes yet.
    Please wait...
  • Juro 321 says:

    Big thanks! For the second time with same problem I found this useful answer :)

    No votes yet.
    Please wait...
  • levchamp says:

    Unfortunately it has not fixed my machine in that the keys are still not functioning when first pressed.

    Is there anything else I can try?

    really need help on this,

    Thanks

    No votes yet.
    Please wait...
  • georgik says:

    @levchamp: Which keyboard layouts do you have in keyboard layout list?

    E.g. English (United States) – US works.

    No votes yet.
    Please wait...
  • Nasir says:

    Thanks man its solved

    No votes yet.
    Please wait...
  • Don says:

    @levchamp

    Might need a restart? I know i had everything switched and it wasn’t working.

    Restarted and boom – problem solved

    No votes yet.
    Please wait...
  • Mariam says:

    Yeah, that’s perfect. I really hated this problem.

    No votes yet.
    Please wait...
  • Kwiz says:

    You are the best! This problem was irritating me and I was about to get tech support which would have been a huge hassle. Thanks a bunch!

    No votes yet.
    Please wait...
  • Harsh says:

    Thank you very much. This has been bugging me from the day i got my Ultrabook. I can now type ” without a space – what a relief!
    Thanks.

    No votes yet.
    Please wait...
  • Tristan says:

    Thank you so much for this, i have a US layout keyboard but i live in the UK, this problem was driving me insane for nearly 2 years.

    Can’t thank you enough.

    No votes yet.
    Please wait...
  • Jason Brown says:

    Thank you so much! I’ve been dealing with this on my Inspiron 15r for a year! Figured it wasn’t that big a deal to get fixed.

    No votes yet.
    Please wait...
  • Dani says:

    thank you!

    No votes yet.
    Please wait...