How to install .NET Core 2.1 on Linux Mint 18.3 Sylvia

Default instructions for installation of .NET Core 2.1 do not contain instructions how to install the technology on Linux Mint.

You may have a temptation to go with Ubuntu instructions, but you’ll end up in troubles with installing libicu60 or libicu57.

The instructions compatible with Linux Mint 18.3 Sylvia are instructions for Linux Debian 8 (not 9).

Commands for repository configuration:

wget -qO- | gpg --dearmor > microsoft.asc.gpg
sudo mv microsoft.asc.gpg /etc/apt/trusted.gpg.d/
wget -q
sudo mv prod.list /etc/apt/sources.list.d/microsoft-prod.list
sudo chown root:root /etc/apt/trusted.gpg.d/microsoft.asc.gpg
sudo chown root:root /etc/apt/sources.list.d/microsoft-prod.list

Commands for installation:

sudo apt-get update
sudo apt-get install dotnet-sdk-2.1

Just for the record, the content of /etc/apt/sources.list.d/microsoft-prod.list is:

deb [arch=amd64] jessie main
Facebook Comments
Rating: 3.3/5. From 4 votes.
Please wait...

28. June 2018 at 7:12 - Software engineering (Tags: , , , , ). Both comments and pings are currently closed.

One Response to “How to install .NET Core 2.1 on Linux Mint 18.3 Sylvia”

  • Muzical says:

    ➜ ~ sudo apt-get install dotnet-sdk-2.1
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    dotnet-sdk-2.1 : Depends: dotnet-runtime-2.1 (>= 2.1.3) but it is not going to be installed
    Depends: aspnetcore-runtime-2.1 (>= 2.1.3) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

    What did I do wrong? >.<;;; I tried sudo apt-get install for the runtime but it eventually gives me the same error except citing a lib that apt says doesn't exist.

    Rating: 5.0/5. From 1 vote.
    Please wait...