qt.qpa.plugin: Could not load the Qt platform plugin “xcb” in “” even though it was found.

After the installation of QtCreator on Linux you might get following error messag when launching the application:

qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.

This application failed to start because no Qt platform plugin could be initialized. 
Reinstalling the application may fix this problem.

It is likely one of libraries required by xcb is missing.

To resolve this problem find libxcb.so and run ldd to identify the missing library.

find ~/Qt -name libqxcb.so -exec ldd {} \; | grep "not found"

Install the missing dependency. E.g.:

sudo apt-get install libxcb-cursor0

28. February 2024 at 10:14 - Software engineering (Tags: , , ). Both comments and pings are currently closed.

Comments are closed.